wuliaonimei博客
随机文章
随机文章

yii框架的安装配置

时间:2015年08月03日  分类:php  标签:php,yii,安装,github  评论:0

安装 Yii

你可以通过两种方式安装 Yii:使用 Composer 或下载一个归档文件。推荐使用前者,这样只需执行一条简单的命令就可以安装新的扩展或更新 Yii 了。

注意:和 Yii 1 不同,以标准方式安装 Yii 2 时会同时下载并安装框架本身和一个应用程序的基本骨架。

通过 Composer 安装

如果还没有安装 Composer,你可以按 getcomposer.org 中的方法安装。在 Linux 和 Mac OS X 中可以运行如下命令:

curl -sS https://getcomposer.org/installer | phpmv composer.phar /usr/local/bin/composer

在 Windows 中,你需要下载并运行 Composer-Setup.exe

如果遇到任何问题或者想更深入地学习 Composer,请参考 Composer 文档(英文)Composer 中文

如果你已经安装有 Composer 请确保使用的是最新版本,你可以用 composer self-update 命令更新 Composer 为最新版本。

Composer 安装后,切换到一个可通过 Web 访问的目录,执行如下命令即可安装 Yii :

composer global require "fxp/composer-asset-plugin:~1.0.0"composer create-project --prefer-dist yiisoft/yii2-app-basic basic

第一条命令安装 Composer asset plugin,它是通过 Composer 管理 bower 和 npm 包所必须的,此命令全局生效,一劳永逸。 第二条命令会将 Yii 安装在名为 basic 的目录中,你也可以随便选择其他名称。

注意:在安装过程中 Composer 可能会询问你 GitHub 账户的登录信息,因为可能在使用中超过了 GitHub API (对匿名用户的)使用限制。因为 Composer 需要为所有扩展包从 GitHub 中获取大量信息,所以超限非常正常。(译注:也意味着作为程序猿没有 GitHub 账号,就真不能愉快地玩耍了)登陆 GitHub 之后可以得到更高的 API 限额,这样 Composer 才能正常运行。更多细节请参考Composer 文档(该段 Composer 中文文档期待您的参与)。

技巧:如果你想安装 Yii 的最新开发版本,可以使用以下命令代替,它添加了一个 stability 选项中文版):

composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-basic basic

注意,Yii 的开发版(dev 版)不应该用于生产环境中,它可能会破坏运行中的代码。

通过归档文件安装

通过归档文件安装 Yii 包括三个步骤:

  1. 从 yiiframework.com 下载归档文件。

  2. 将下载的文件解压缩到 Web 目录中。

  3. 修改 config/web.php 文件,给 cookieValidationKey 配置项添加一个密钥(若你通过 Composer 安装,则此步骤会自动完成):

    // !!! 在下面插入一段密钥(若为空) - 以供 cookie validation 的需要'cookieValidationKey' => '在此处输入你的密钥',


上面是yii官方的安装文档 但是里面有一个细节说的不明显,害得我一直找。

composer global require "fxp/composer-asset-plugin:~1.0.0"composer create-project --prefer-dist yiisoft/yii2-app-basic basic

当你执行这条命令的时候需要你的github账号获取一个可执行的token秘钥 

地址为https://github.com/settings/tokens

选择Generate new token 然后继续选择这个秘钥所具有的权限就行了。 

http://localhost/basic/web/index.php 测试页面

(]3(8XWBX14RQXXWL8ZLI`9.png

出现这个页面就表示安装成功了。


第二种检查方式 

http://localhost/basic/requirements.php 测试页面

没报错就表示安装成功 有报错的话就开启PDD PHP扩展

extension=php_pdo.dll

php.ini中去掉这句注释就行。

当然你得首先保证你的php是5.4以上的。


评论列表

回复

你正在以游客身份访问网站,请输入你的昵称和 E-mail

Copyright ©2014-2015 Develop by Skilly. Go to the Top